Zone Loading Issue and other bugs

1 reply [Last post]
Saphilly's picture
Saphilly
Offline
Jarl
Joined: 10/29/2016

Hello! My username in game is SleepyBreeze. I've been waiting two weeks for some help and I'm getting to the end of my rope, but my forum name was finally accepted.

 

Less than four days after I started playing SOD I ran into the issue that Berk wouldn't load. The progress bar would appear full and the music and sounds for the zone would start, but no matter how long I waited I would never actually get into Berk. All of my quests are at Berk now and I can't progress. I looked everywhere for a solution and everything told me to ask costumer support, but it's taking a very long time, and as I new player I just really want to play my game...

I'm also having trouble compleating the current lab quest with Meatlug. After Meatlug spits out the charred wood I can't freeze it like the game wants me to because all of the buttons disappear and I am unable to do anything other than quit the game.

There are a mirid of other bugs that are bothering me, but these two are the only things stopping game progression. The last one I wanted to mention was that I sent a family member an invite on facebook through the new in game invite system. They got the invite and signed up, but I never got my gems/diamonds. They also can't get into the game. Their game crashes every time they finish making their character.

Someone please fix my account issues, I've been waiting so long and I just want to play again.

 

Sincerely, SleepyBreeze

Brynjolf's picture
Brynjolf
Offline
Forum Admin
Joined: 08/29/2013
Hello.

Hello! Thank you for reporting this issue. Have you tried to clear your browser or unity cache? Sometimes doing this can help resolve certain issues. Regarding the Meatlug issue in the lab, our team is aware of this issue and is actively working on it and trying to get a fix in soon. If you could please provide us with your username and viking name. Thank you!