"Unwelcome Visitors" Quest Glitch

3 replies [Last post]
Hotrod882's picture
Hotrod882
Offline
Jarl
Joined: 12/10/2014

Ok I'm loving this new expantion pack! However, when Hiccup told me to go over to where the beserker ship is and talk to Mildew. Fungus is there but Meldew isn't. Meldew is inside the ice cave by the Groncicle nest. When I tap on him to talk, he won't respond. I've logged on and off but still the same problem. Has this happened to anyone? If so, please tell me what to do. If the admins is reading this, please respond. I really want to complete this quest so I can do other quests.

Fury of the night's picture
Fury of the night
Offline
Supreme Viking Champion
Joined: 02/26/2015
Maybe try going into a

Maybe try going into a different browser? It might let you talk to him.

__________________

 

Welcome to my Signature

 

                                 

Name: Furywhisp ( I know it's spelt wrong)         (Not active anymore.)

Clan: Phantom Lords

My first dragon, Spineshot the Deadly Nadder

 

                                                                                                                                                             Scensoredtriker(Razorwhip) and Foxy(Speedstinger) and Ringwing (OC Skrill)          

   

 

My 2 Nightfuries, Emerld and Silverpaw.                                              

  

 

Credits to The Eplictic Eight, Twistedclaw, Dragon Drawer, Nessie, Defy, Anuiravenwolf, Carmine, Duskdaybreak, Nessie, and

Hotrod882's picture
Hotrod882
Offline
Jarl
Joined: 12/10/2014
I tried

I tried my Iphone, Steam, even on Firefox, and nothing. It doesn't help. It's like since I did not do Meldew's quest before the "Unwelcomed Visitors" quest it doesn't work. I mean he has the question mark above his head and still nothing, plus he's in the ice caves but he should be at the place where Hiccup is and where the Beserker Ship was.

Tilarta
Offline
Viking Warrior
Joined: 12/05/2013
I too am having this

I too am having this problem.

Tried the Steam Game and the mobile App, Mildew doesn't respond in either version of the game.

 

If I had to guess, a possible conflict could because it's granting the mission out of sequence, it's appearing at the wrong point.

For the majority of the expansion, Mildew has been hanging around his house, being well, cantankerous and unpleasant as normal.

But from the looks of his current location, it's as if he just arrived on the island and hasn't moved to his current home yet.