Unable to Log-In After Sending a Password Reset Request.

No replies
EchoTheWayfarer
Offline
Viking Warrior
Joined: 04/28/2020

This issue occured yesderday (10/18/20). My computer is a Laptop running Intel CORE i7, NVIDIA Geforce GTX, with 16 GB RAM. Currently runs Windows 10, and I commonly use Google Chrome but recently switched to the DuckDuckGo extension. I was trying to log into the website that day and couldn't for the life of me get my password to work, so I tried reseting it. I know I'm using the right username and email to retrieve that info, but I kept getting an error along the lines of an error occuring during my request. Figured, ah well I'll just play the game then I don't need to be that much in the website. Turns out it logged me out and won't accept my old passwords. Tried reseting through the game page and also got an error. It's been a day since then, I figured I'd wait incase there was actually some minor issues with the servers and what-not but still can't get a request to go through. Been checking my email for any messages, especially in the Spam folder. Still can't log on nor get a new password. I might try again later after turning off/uninstalling the extension, but is there anything else I can do? 

 

Thank you.

AttachmentSize
Screenshot (1877).png1.38 MB
Screenshot (1878).png806.74 KB
__________________

Editing As I'm switching with Viking as my Main