Snoggletog Quest not working

3 replies [Last post]
MahaAhmed
Offline
Jarl
Joined: 10/20/2016

On my other account the Wrangler, snoggletog quest isnt working for me, i can only do half the quest till the zippleback island part then my game crashes and resets my progress, this keeps happening, does anyone know how to solve this

__________________

Welcome to my siggy

 

I am not very intertaining just a normal 18 year old living a normal boring life :)

 

This is my signature Guardian Icy, she will bite whoever

gets her angry

 

RAWR

 

About Me 

Irl

Name: Maha

Gender: Female

Age: 18

Hobbies: Gaming, Sleeping, Playing basketball

   

In Game

Viking Name: NightmarreIcey

Gender: Female

Friend Code:

Clan: dragon training happiness (searching for a new one)

 

Favorites

Color: Purple (more like a obbession)

Food: PASTA!!

Animal: Panda (they soooo cuteee)

Sports: Cricket(just to watch tho) and Basketball

Show (currently): Luciefer 

 

 

Enough about me....

 

 

Here are my babies

Razorwhip: Midnight (Main Dragon)

Sand Wraith: Shadow

Deadly Nadder: Breeze

Nightmare: FireHeart

Zippleback: Toxic

Speed Stinger: Bolt

Armour Wing: Amethyst

Groncicle: Frosty

Deathsong: Rythme

Eruptodon: Quake

Singetail: Ingenous

Nightlight: Dart

 

 

(If anyone is good at drawing and kind enough i would like a purple colored dragon to match my signature)

HypergoofTheFriendlyBerserker's picture
HypergoofTheFri...
Offline
Supreme Viking Champion
Joined: 02/10/2015
Wiggles the whispering d.eath ate my subject

Mine is glitched too. Mine starts infini-loading when I click the last turkey and I have to close the game.

I now avoid that quest on other vikings and do other quests on the affected one. I don't have an answer to fix but am adding more details to how one version of the glitch works.

I can say I'm not too mad about it because I'm glad that at least only one quest seems glitched as last event several were.

I'd still like it fixed but at least it doesn't stop me earning my cookies.

__________________

 

Bumbles the candy loving Lazersight Vesperwing who likes to stalk me for my food.

Adopted from goldenfury360 who made the species.

Lineart done by NightmareRebuff

 

 

 

 Flint the over curious gluespit.

Adopted from chameishida.

 

Chelsy, the least frightening indominus rex there ever was. Color shifting joke charicter extrodinare. Art by TosiLohi.

AgentPanda2002's picture
AgentPanda2002
Offline
Forager
Joined: 07/31/2020
...

I had that problem to, but I somehow fixed it. I think that when it went infi-loading, I got on my dragon and fly toward the ocean. That showed the map, I clicked on New Berk, then the rest of the quest showed up. I hope this helped!

MahaAhmed
Offline
Jarl
Joined: 10/20/2016
I tried that I am not able to

I tried that I am not able to move or click anything at all when the loading gear pops up but thank-you for the advice