Ran into a Glitch in Rise of Stormheart, and issued a Support Ticket!

5 replies [Last post]
Supreme Viking Champion
Joined: 06/27/2016

I have run into a Glitch in Rise of Stormheart Expansion Quest.

Because I could not resolve it I sent in a Support Ticket!

I have not add this thread to Support/Mobile/Report Bug because I play on a StandAlone PC, not a Moble device and was not sure where to post this information. If this is wrong place to post this thread, I apologize, and I hope the Game designers will feel free to move this thread as needed. 


Rise of Stormheart Expansion Glitch:  Occurs in the underwater section, where our Viking is to find an underwater cave, where Stormheart has hidden a crate of Grimora venom that our Viking needs to destroy.  

Glitch occurs after I has clicked on the Diving Bell button and my Viking has re-entered the Diving Bell for air. The Screen freezes on an ocean scene with both the diving bell and the breathing gauge on the screen. I waited for the re-dive button to appear, but after the first or second dive back into the water, it does not reappear on the screen at all. I tried multiple times to get the scene to continue or restart. It stays frozen! I clicked on everything on the scene, including the rope that brings the Diving Bell back to the surface. Nothing Worked!

I could not even exit the scene, because there are no game controls on the screen. There is no portal map, which can be used to move between game locations, or any other game controls on the screen. I literally had to close the game, to get off this glitched quest scene.

I can still play on SoD, but I can no loner complete this expansion quest or move onto another Expansion Quest. So, I posted info, just in case, others run into this problem. Hopefully, no  one will. :)



First, I issued a Support Ticket, but since this is the weekend, I will not hear anything until Monday, 9-26-22, at the earliest.

Second, I have searched this issue through the Forum Threads, on my online Browser, and on the latest Dreamworks SOD Wiki.

I found nothing that matches. However, I did find info on the Wiki that gave me updated info on this specific underwater portion of this quest. I had hoped that the Wiki info would help me get through or around the glitch on the Rise of Stormheart quest, but No it did not help.

Third, i have gone thru quite a number of re-downloads, re-install and re-starts of my computer and of the Game, and nothing has enabled me to continue my quest. Hopefully, Support will find a solution. 













Infinent's picture
Viking Warrior
Joined: 03/11/2018
subject disappeared like the deathsong armour

Yee i've seen a few, and written a post on this issue too.

  I think and as far as i'm aware i think they're working up a pacth for it.


A reply from Goony is in the first linky here:  hope this helps maybee ^^'



 Fingers crossed they'll have a fix for it up soon!!


 death song armour no.1 advocate :D    


✉ Advocate For Humility       ✉ Breaker Of Games       ✉ Proclaimer Of Epic-ness


I joined SoD early 2014, left for a bit in 2018... But am hopefully back for good now, being 2022.

Hope to see you around some time. <3


       「 vikings !! 」

  infinent[ est 2014 ]   trophy count: 69,420.

    probIems[ est 2020 ]   trophy count: 38,000 +


     「 clans !! 」

  Bandito Gang,      The Phantom Lords.  [ infinent ]      Arrows Of Horus.  [ probIems ]

    Spirit Of Valhall.   The Dragon Racers. [ former / cumulative ]


     「 socials !! 」

  discord. [ surfnturf#0002 ]   sod instagram. [ infinent_ ]   instagram. [ cascqde ]   spotify. [ gabs but not ]   steam. [ shiny turd ]

hobzmad. the end.


Supreme Viking Champion
Joined: 06/27/2016
Thank you for your reply,

Thank you for your reply, Infinent. I appreciate the information you've given me.  The info from Goony is especially useful. I went back and reread the Wrath of Stormheart that I found on Dreamworks SoD Wiki.

It talks about the problems occuring with the continuing story line involving the underwater adventures with the Krafin from the Secret of the Leviathan expansion quest. It also provides information on how to get through these issues, so that you can complete the expansion quest, Wrath of Stormheart. Very good information that will be very useful when I am able to start the next ongoing expansion Quests.


Unfortunately, my current problem occurs in the previous Expansion Quest, Rise of Stormheart. It also occurs in am underwater sequence (Animation) when our Viking has to find an underwater cave and destroy the Grimora Venom that Stormheart created and hid in the underwater cave. 

I'm still rereading through all the Rise of Stormheart quest info on the Dreamworks Wiki. I hope to find a solution. . . Will post my results later. 


Again, thank you, Infinent, for the directions to the additional informaton provided by Goony. That is invaluable info and help! I will put it to good use when I get to that next expansion quest. And, Goony, thank you, for all your hard work on all the  problems and glitches that you solve and fix for us. Salute! Three Cheers, Goony!



GoonyBard's picture
Game Developer
Joined: 09/29/2021
Hey there!

CoalBright wrote:

And, Goony, thank you, for all your hard work on all the  problems and glitches that you solve and fix for us. Salute! Three Cheers, Goony!


I can't take credit for this one, my coworker has been hard at work fixing the issue. I'll pass along the kind words though, thank you!


I checked on the status of the issue and it seems like it's been fixed, so we should have the fix going out in the next update. Sorry you all had to wait so long!


Dragon tamer and frontend dev for SoD since 1/21. I don't answer PMs, reply to me or mention me by name (GoonyBard) and I'll answer when I can.

Supreme Viking Champion
Joined: 06/27/2016
TY for your response, Goony. I appreciate

TY for the response, Goony.  I appreciate your passing on my thanks and appreciation to the appropriate member of the team. 


CB  :)


Supreme Viking Champion
Joined: 06/27/2016
Update: Solution found

Update: Solution found on the Dreamworks Wiki, under the section titled Underwater Sections:


I admit, I had trouble figuring it out because the diving bell was such a crucial part of the underwater sequence when I first did the quest, years ago. The information on the new control never indicated that one should ignore the diving bell, and I kept assuming it was necessary. As a result, every time I used it I got stuck in it. The new control button is easier and faster. It got me quickly from the ocean surface to the ocean floor. In addition, the gallery of underwater images of this sequence gave me the necessary info to find, enter and exit the cave quickly. I found all the information, including the images, on the Dreamworks Wiki under Underwater Sections

Very happy to have found the solution. I will be using the Dreamworks Wiki much more now!!! 
P.S. Goony, feel free to move or delete this thread, since I created another thread on the same subject listed under,  Forum » Mobile » BugReport. Original Thread link is: https://forum.schoolofdragons.com/content/underwater-air-sections-bugged-goonybard-assistance-needed