Numerous problems including membership, quests, server issues

1 reply [Last post]
foxchaser
Offline
Jarl
Joined: 01/16/2014

1) Membership is broken. I am a member, but when I log in, it says that I have to pay gems to become a member to unlock membership features which should already have been unlocked. E.g. extra profiles, access hero dragons at flight club, icon next to username changed back to silver. On website membership page it says "The current user is already an active member."

 

2) Quest to rescue someone in the wilderness given by headmaster requires dragon to glide to a platform with a beacon. Dragon cannot glide there, will drop too far even when holding W and the boost button. Quest cannot be completed.

 

3) Quest from Heather to burn items requires coal from gobber. Quest log states to get coal from gobber in Berk. Gobber does not respond, whether in Berk or Wilderness. Quest cannot be completed.

 

4) Last night approx 1AM PST the server crashed. I was in game and all interactions resulted in spinning gears followed by the error "the game has encountered a server error", including quests, purchases, and harvesting. I could switch between zones and see other players moving around but everything else was broken. I tried rebooting and logging back in but the login page was broken. Yes, I had cleared my cache. I get to the login page, which takes very long to load, and after entering my username and password and hitting the login button, I got a 404 error. I tried this in both firefox and google chrome. The server was effectively toast and I could not harvest my produce. All other websites were fine. I logged in today to dead plants.

 

5) Eel roast minigame is broken. Will not respond to spacebar, so will always hidewithin first few levels. The spacebar only ever worked once, during which I managed to get up to level 50 before a power outage wiped my score.

 

6) My fishing level is jammed at level 1. Not sure if this is supposed to change or not.

 

I use both google chrome and firefox on PC Win XP and Win 7. When I encounter a problem I switch computers and all of the above issues have been reproduced on both browsers on both computers.

 

7) Not reproduceable: Unity crashed with game content error in Berk, just walking.

foxchaser
Offline
Jarl
Joined: 01/16/2014
Updates on issues: 1)

Updates on issues:

 

1) Membership still broken. Same condition. I will be forced to initiate a paypal dispute and chargeback if it's not resolved.

2) Gliding seems fixed.

 

3) Quest was broken due to race condition with issue 2.

 

4) Server hasn't crashed since. However, several times on login, there were no other players, regardless of MMO setting. Switching profiles did not fix this.

 

5) Still broken.

 

6) Still the same. I guess the fishing level system just never worked.

 

7) Numerous more unity crashes encountered. At least 5 within 24 hour period.

 

8) Taxi occassionally stuck in space, no rings, no portals, need to reload game and download all game data again.