"The Fog Rolled In" bug

No replies
Shockfrost's picture
Shockfrost
Offline
Berk's Power Player
Joined: 09/06/2015

So I think I figured out what was going wrong with this quest, so hopefully anyone reading this won't get locked out of a gigantic quest chain that I can't do right now...Keep in mind this is what I believe happened to me, so it may not be 100% accurate and more than a little biased.

 

During the quest mentioned in the title, you need to gather materials in order to make a sunstone compass (I believe).  At one point it tells you to pick up 3 scraps of metal by Gobber's house.  BUT, for some inexplicable reason, it gives you the quest prompt to move to the next step after grabbing ONE of these scrap piles.  Moving onwards will prevent you from grabbing the other two scraps and lock the quest out, because the game wants you to have 3 scraps.  After learning this I tried to go back, but the scraps were long gone...

 

Filed a ticket a week ago when first found the quest bugged, then tried to update it today after I pieced together what might have happened, so we'll see if I hear back from them in the next month.  In the meantime all players, PLEASE don't make the same mistake I did.  Grab three scraps, get your dragon to do it, just something that doesn't leave you with two dragons who would love some delicious quest exp...