egg issue

5 replies [Last post]
Darkstorm's picture
Darkstorm
Offline
Wilderness Explorer
Joined: 11/07/2014

Hi I hope everyones well,
Ok It's the storm cutter egg issue.
I have cleared my cache, and dealt with cookies and such with no luck
I brought an egg and it vanished when placed on the podium thingy, I then I dont know why Brought another egg (1200 gems spent) 
The second egg shows but for the last day since i got it all i get is Pet create error when trying to hatch it. I have gone to all the relms and races to encourge files in the background to load hoping they might help, but nothing.
Please (gets on knees and begs) can someone, anyone for the love of socks sort this issue. I emailed the support but from previous issues know they can take 2 weeks+ an answer. Im conserned this egg issue will stop any other eggs being able to hatch as the Storm cutter eggs there.
Please help

__________________

Darkstorm's picture
Darkstorm
Offline
Wilderness Explorer
Joined: 11/07/2014
Thinking about it if i got

Thinking about it if i got say another dragon egg  say a nadder or something and hatched that first then did the storm cutter does anyone think that could work?

Aprikoze's picture
Aprikoze
Offline
Supreme Viking Champion
Joined: 05/04/2014
You might just lose both eggs

You might just lose both eggs :\

__________________

Darkstorm's picture
Darkstorm
Offline
Wilderness Explorer
Joined: 11/07/2014
Thats the thing is the create

Thats the thing is the create pet error only to the storm cutters or could it effect other eggs? I just wish the site would put out a "we know theres an issue we will report in .... hours with an update" As good customer service. That way people would feel something was being done over the issue, I feel so left out when i see other players with their dragons. hehehe, Nothing ever quite goes right ehehe

Aprikoze's picture
Aprikoze
Offline
Supreme Viking Champion
Joined: 05/04/2014
Sod is glitchy, but it's

Sod is glitchy, but it's nothing you can't get used to :)

hsimone1's picture
hsimone1
Offline
Wilderness Explorer
Joined: 06/11/2014
I'm having the exact same

I'm having the exact same problem >.< and PMed an admin over the weekend.

 

It's very frustrating considering I'm a 3 month member and have invested considerable $ into this game. Have not had issues until this stormcutter problem. Very disheartening first world problem lol. 

__________________