Can't log into my account because loading takes forever

5 replies [Last post]
niflanker's picture
niflanker
Offline
Jarl
Joined: 12/14/2020
I am now experiencing this issue for the second time, and would greatly enjoy some feedback: 
I am essentially locked out of my account. Whenever I select my viking from the beginning screen, it takes forever to load; I hear the Training Grounds music in the background, and it loads to 100%, but I can't play. I've let it load for a couple hours, still no luck. 
I have contacted SOD support for this, and they have fixed it once. I am now aware that it is an programming-related issue EXCLUSIVE to my account. 
Reinstalling, updating and restarting my system serves no solution. I have already cleared my Unity cache, still no luck. 
I am aware this is an issue the team is able fix in their programming department, but I have been very frequent in their inbox lately and hope there's a fix I can do on my own to, well... bug them less, haha. 
If anybody has experienced this for themselves or happens to know a way to fix it, that would be greatly appreciated. 
Thank you!  
 
Also, a bit of a side note:
For some reason, whenever this bug happens, my viking looks different in the menu screen. She's wearing a whispering death mask, has basic starting clothes and her hair is bright red [all of which is incorrect for my character]. I don't know why this is. I CAN log into my farm, play races and other minigames, but the issue arises when I try to enter the main game, e.g. Berk, the School, Training Grounds, etc..
 
Computer: PC 
Operating system: Windows 10 Pro 64-Bit 
Web browser: Chrome (even though I play it as a standalone app on my computer...) 
What I was doing when it occurred: I was participating in a Battle Event in the Training Grounds, when suddenly the game logged me out. So of course I logged back in, and the issue was back up and running; I couldn't play, the loading screen took forever. 
When the error happened: Today, after playing for a couple hours when receiving access back to my account (yup, it'd been locked for like a week prior). It's back, to my dismay... This has ONLY happened once the Snoggletog update happened! I've never experienced this issue prior, and I used to play this game A LOT.
Graphics card: NVIDIA GeForce GTX 1070 
Screenshots:  So yeah, my viking looks very odd and different from her actual self. Also imagine that loading screen, but going on for hours with the occasional "your viking is idle, press OK to continue"... as if I'm even playing, lol
 
Morgaerwen's picture
Morgaerwen
Offline
Berk's Power Player
Joined: 04/17/2020
I think-FLARE, GIVE ME MY LUNCH BACK

I don't have any advice, but what I do know is that this glitch isn't entirely exclusive to you.

Maybe you could try a different device?

Good luck sorting this issue out!

__________________

 

Morgaerwen Lossëndil

 

You can call me Morg if the Elvish is a mouthful. Former ambassador

and current member of Z War Clan, digital artist

-----------------------------------------

Currently kind of inactive

-------------------------------------------

Profile art by me

---------------------------------

The bulk of my signature is HERE

**Please note: My signature has some GIFs. I don't think they should cause any issues for photosensitive people(they are more gradual, and not particularly flashy), but you may want to proceed with caution**

niflanker's picture
niflanker
Offline
Jarl
Joined: 12/14/2020
Good to know

It's good to know this issue isn't exclusive to me at least. When I can, I will try any different devices available to me. Thank you very much!

niflanker's picture
niflanker
Offline
Jarl
Joined: 12/14/2020
Good to know

It's good to know this issue isn't exclusive to me at least. When I can, I will try any different devices available to me. Thank you very much!

Varku's picture
Varku
Offline
Supreme Viking Champion
Joined: 06/14/2015
~

I'm familiar with this. It's a super annoying... bug? I think it's a bug. I very much doubt it's a glitch? This happens 50% of the time for me actually, but restarting usually works. Sucks that it doesn't for you! 

 

In the worst case, clearing the local caches (not the Unity web cache) can work, and if that doesn't work out, a full uninstallation might do the trick. The windows uninstaller does not remove application data and registry files so it doesn't properly remove software. A 3rd party uninstaller like Revo, which allows you to delete registry files as well as temporary data, does a better job at uninstallation.

 

It's a long shot, but it's something you could try? I'm not sure about your changed viking, though! That is odd.

__________________

★·.·´¯`·.·★ arт ιѕ нard ★·.·´¯`·.·★

Neo // Engineer, cabbage slapper, crappy artist exteme
 
 

Extra links:

 

niflanker's picture
niflanker
Offline
Jarl
Joined: 12/14/2020
Thank you!

I'm currently trying to log on to the mobile version, but Revo does make a couple favorable changes. I will keep working based on your advice. Thank you very much!