ADMINS ASSISTANCE PLEASE Lost a dragon in the update!!!!!!

2 replies [Last post]
Peryton's picture
Peryton
Offline
Jarl
Joined: 08/21/2014

So with the amazing update today, which it is amazing, and totally appreciate the admins hard work on it, but I had just hatched a smokebreath this morning before I was able to access the update. Then in my excitement I didn't realize until I tried to switch my gronkle out for my new smokebreath that she was gone! 

 

I had had bought the defenders of berk dragon bundle specifically for this smokebreath, and now I have all the other eggs and the Boulder stable but my smokebreath is gone. It was an expensive bundle and I would really love this issue solved quickly!

 

ps I have already cleared my cache, and checked back in the hatchery, and in my bag for the egg in case it reverted.

Orcawave101's picture
Orcawave101
Offline
Supreme Viking Champion
Joined: 07/11/2014
I have not lost any dragons,

I have not lost any dragons, but the Bone Knapper helmet no longer works....

   I think there may be a couple bugs - though its to be expected.

 

I would PM an admin about this, they may get it faster that way.

__________________

 

                                      My Signature is under construction! 

Joshkurt's picture
Joshkurt
Offline
Chief
Joined: 09/12/2014
All the horde pack except the egg missing

All the hordes pack except the egg were missing since the update hope the admin read this, i lost my toothless helmet too after i update this game i cant even do fishing, hope they can fix this soon

__________________

         ROAR !