Admin Please Repy ASAP!

6 replies [Last post]
PhantomFrostWolfe
Offline
Jarl
Joined: 07/07/2014

I had left a forum inquiry about an issue with the Stormcutter Egg/Hatching.  I will repost. Not sure who is all an admin otherwise I would pm you:

 

Ok I am more than just a little upset right now.  I just purchased recently one of the new Stormcutter Eggs.  Had no problem with that.  I put the egg into incubator, no problem with that either.  When I go to force hatch it, the egg just goes and disappears on me. You can understand now why I am more than a little upset, especially spending 800 gems on the thing(and thats the sale price!) From my understanding this is a huge problem with this product atm.  I looked at forums for any solutions and cleared the cache for both browser and Unity player.  I now have some random number named Stormcutter on my character but there is no way to get it to hatch or place egg that disappered.  There is also no egg in inventory but it still shows a Stormcutter that I cannot access.  I hope someone can resolve this issue soon or at the very least refund my gems to me.  I did not however get charged for the force hatch so I understand that I will have to pay it in order to do so.

 

My character name and forum username is PhantomFrostWolfe. If you need my actual username I will pm that too you.

 

 

Thank you

hsimone1's picture
hsimone1
Offline
Wilderness Explorer
Joined: 06/11/2014
I've lost one stormcutter egg

I've lost one stormcutter egg and one refuses to incubate, but remains in my inventory. I get the "failed to create pet" prompt. I have over a dozen dragons and have never had a problem hatching those, even when they were new releases. I've PMed an admin, but I'm not expecting a response till Monday (I hope). I'm really peeved at myself for purchasing two, but some customer support would be great. It makes little sense to release new dragons a day before administration takes the weekend off, especially when it's a much anticipated dragon >.< 

__________________

PhantomFrostWolfe
Offline
Jarl
Joined: 07/07/2014
Yeah same thing with you I

Yeah same thing with you I have never had this problem with a new egg either!!  I just hope it gets resolved soon.  Especially for those who went to buy more than one egg :(
 

bubbles5498's picture
bubbles5498
Offline
Berk's Power Player
Joined: 07/30/2014
Unfortunately the admins

Unfortunately the admins don't work on weekends.  All you can do right now is send them a PM and maybe make another forum post on monday.  Your not the only one who lost an egg, so the admins should (hopefully) get to it soon.

__________________

PhantomFrostWolfe
Offline
Jarl
Joined: 07/07/2014
ah I wish I had know that

ah I wish I had know that before hand D:

 

NightFury13's picture
NightFury13
Offline
Berk's Power Player
Joined: 11/02/2014
It might be because you need to refresh or update it...

 This same problem happened to me, but, if you are playing on mobile, you can update the game (in the app store) and when I came back, my stormcutter was in my stable! Or maybe you can refrsh it (if you play on a computer).

__________________

 

  

 

 Eclipse and Me

Siren's picture
Siren
Offline
School of Dragons Admin
Joined: 09/10/2013
Hey PhantomFrostWolfe, we

Hey PhantomFrostWolfe,

we apologize that you are experiencing issues with your new Stormcutter egg. We are aware of this issue and we are trying to resolve it as soon as possible.