About to Lose It

12 replies [Last post]
alexpanciera87
Offline
Jarl
Joined: 09/08/2014

I just sank the better half of ONE HUNDRED DOLLARS into this spaztic excuse of a game, I am seriously at the end of my rope here.

 

As an aside, why have Skrill eggs been added to the default hatchery options, but not the Rumblehorns?  This could have gone so much easier...

 

Running FireFox on a Mac, decided to try the game out cuz the game options for this franchise are few.  First I ran into the little problem of the game timing out on character creation and then telling me my name had already been chosen, WHEN WHAT ACTUALLY HAPPENED WAS THAT THE CHARACTER WAS MADE JUST FINE, THIS HACKJOB OF A GAME SIMPLY DIDN'T INFORM ME OF THIS UNTIL I TRIED GETTING ON THE MOBILE VERSION, WHICH IS WORSE.

 

After determining that, despite the CLEAR PRESENCE of the Skrill eggs, the dragon I wanted was NOT available off the bat, I bit the bullet and bought a membership.  Since at NO POINT DOES THE GAME TELL YOU HOW MUCH IT WILL COST, most of the gems from the membership package went into getting rid of the extra characters.  So I had to go buy MORE GEMS just to get the Rumblehorn Egg.

 

Guh.

 

Once I FINALLY had my dang egg, the game tripped a flag that sent me to the player stable, which I hadn't unlocked yet.  Afraid that NOT hatching the egg in the lava pit back in the hatchery would screw the game up and somehow LOCK me out of completing the quest and doom my character to an existence of never actually playing the game, I tried to return to the hatchery and hatch the Premium Egg there.

 

The stupid game locked up.  Now I'm in the Hatchery with NO PREMIUM PAYED FOR WITH MY OWN MONEY RUMBLEHORN EGG in my inventory, and no way to enter the player stable UNTIL I hatch an egg.  The room layouts don't make ANY SENSE.  There seem to be AT LEAST two map exits that go to the same place, and I'm pretty sure I tripped a cinematic that was supposed to play BEFORE I got to the island in the first place.

 

I swear, this thing was coded by monkeys.

 

tl;dr?  WHERE THE %&@$ IS MY DRAGON EGG?!  I PAYED GOOD MONEY FOR THIS EGG, I SHOULD BE ABLE TO START THE GAME WITH IT!!!

 

There, I said it, I feel better.

alexpanciera87
Offline
Jarl
Joined: 09/08/2014
Oh wait, there are more than

Oh wait, there are more than three sub-inventories in the back pack.  There it is.

 

 

 

 

 

 

There are still other players and dragons slidding all over the place and clipping through walls everywhere.

alexpanciera87
Offline
Jarl
Joined: 09/08/2014
Still Don't Have My Dragon

I can't do anything with this egg.  I left-click, right-click, click and drag, nothing.

 

I cannot interact with this egg THAT I PAYED REAL MONEY FOR.

FDG21's picture
FDG21
Offline
Chief
Joined: 08/19/2014
have you tried bringing your egg to the lava pit in the stables?

have you tried bringing your egg to the lava pit in the stables? but i understand your frustration, i cant do anything with my game....but i am hoping my faithfulness will inspire the creators or someone to help me....i hope....anyway, i will gladly help if i can, the game may have glitched if this is your first egg, if that is the case have you tried going to the stables and clicking the stand near the lava pit?

kaylawolf91's picture
kaylawolf91
Offline
Supreme Viking Champion
Joined: 07/21/2014
You can't have a Rumblehorn

You can't have a Rumblehorn as a starting dragon even if you are a member. You have to choose one of the dragons in the hatchery as your starting dragon and then you can go to the stable to hatch the rumblehorn. You can then make your Rumblehorn your active dragon as you do the quests and then when your Rumblehorn reaches level 20, you can switch to the other dragon and level them up. Maybe in a future update they will add more dragons to the hatchery but for now, you have to have a hatchery dragon as your starting dragon. 

__________________

t1CK t0ck 8r8k H34DS honk HONK

 

 

alexpanciera87
Offline
Jarl
Joined: 09/08/2014
ARE YOU @$&#%*€ KIDDING ME?!

I swear, if this wasn't my only option...

alexpanciera87
Offline
Jarl
Joined: 09/08/2014
OK, FINE...

If I can't use my Rumblehorn egg yet, I'll get a Skrill...

 

"Members can choose a Skrill Egg.  Become a member today!"

 

AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA...

Brynjolf's picture
Brynjolf
Offline
Forum Admin
Joined: 08/29/2013
In Response

Hi alexpaniciera87,

 

Thank you for taking the time to write and effort to write this detailed report about your gameplay experience. We're very sorry at the majority of the sentiment that you expressed in this thread and we want to address every issue that you brought up so that we can have a better understanding of the problems that you are facing. First, since School of Dragons is seemless online and on mobile, you should be seeing the same thing when you are making your Viking on both platforms. Therefore you should not have gotten a message that said the name that you wanted was already chosen on one device and not the other. But overall, it sounds like you might have already created that Viking name and therefore you cannot reuse the same name of what you already created. If that is not the case, you can privately message us your username and in-game Viking name so that we can take a closer look into your account.

 

Second, prices for membership packages are always clearly indicated, both on our website and in the game as well when you click on the "Become a Member" button in the store. You actually had to select the price package you want in order to proceed, since there are multiple packaging options. We also need some more clarification when you mentioned that "most of the gems from the membership package went into getting rid of the extra characters." Since, you're not able to delete Viking slots or dragons, we are not entirely sure what you meant by this. You have the right to do whatever you want with the gems you receive from membership, the game does not force you to use them in any part.  

 

Now, we understand your frustration at having to buy a Rumblehorn egg with your gems, but as Kaylawolf91 already mentioned in the comment above, the Rumblehorn is unfortunately not available to get as a first dragon, even if you are a member. It is one of the dragons that our team has recently released for Vikings to buy. On a more positive note, we are happy that you are able to find your dragon egg that you thought disappeared, safely in your backpack.

 

We also understand and appreciate your comments and opinions about the layout and design of the game. Our team reads every suggestion and comment from our users so that we can continuously improve and make a better product as we grow.

 

I hope this clears up some confusion and even frustration that you might had regarding the game. If you have any further questions or concerns, please don't hesistate to let us know.

 

alexpanciera87
Offline
Jarl
Joined: 09/08/2014
Cooled off, much calmer, still some issues...

When I logged on to the mobile app, there were about a dozen named Viking characters on the character select menu, and each one took 100 gems to get rid of.  I don't know if your systems can track that, but it happened.

 

I got a Skrill egg, but it took me buying a second membership.

 

Oh, and the chat filter is psychotic.  It blocked such dirty words as 'access', 'nose', and 'one'.  I have to wonder what sort of workarounds people have come up with to make it this stringent.

Moonshine's picture
Moonshine
Offline
Supreme Viking Champion
Joined: 07/19/2014
*Psst... What is a subject?*

With the "I swear, this thing was coded by monkeys", I have to say I agree with you. There are so many bugs and glitches with this game that it's almost unbearable, especially since the *maintenance* last night. That patch was nothing but trouble, but luckily I'm holding out. I'm still EXTREMELY ANGRY at the fact that I received a Gronckle egg from my mystery dragon egg box... Stupid Gronckles. I was planning on getting one of you last.

I know what you're saying: "It's your fault, you took the risk, you bought it," but that doesn't ease my rage. Actually, nothing could but a "Sell" tab in Trader Johann's store.

__________________

.......................................................................................................................

 

I'm a proud member of The Phantom Family!!

 

 

As of 3/28/15, I have two Vikings. My main Viking's name is Alcestis. The other's name is Amarisse. My friend codes for both Vikings are now private. If you really want to be my friend, PM me.

I speak French, JapaneseGerman, and English fluently and I accept translation requests :)

 

GoldenStar1357's picture
GoldenStar1357
Offline
Supreme Viking Champion
Joined: 11/25/2013
Sigh.

 

I previously wrote before in a topic wrote:
 I think some people have forgotten that SoD is only one year old. There are lots of complaining and "I am going to quit" comments. I understand your frustration at the glitches (especially the chat glitch >.<) but please remember that the game is one year old. It is very new, and would have a lot of bugs to be ironed out. If you ask me, this game is actually pretty good in terms of not glitching most of the time compared to others. So please, stop complaining all the time and...well...enjoy the game! And if you do have a glitch that needs to be fixed, just PM the admins instead of making a topic.

__________________

Pins made by Nessie, found here
Apologies for the image-heavy sig!
Note: If images below fail to load at first, scroll the entire page (not my sig) up or down a bit, and the images should pop up.

   ~~Please PM me for my friend code if you want to add me~~

~~Stormwing (Stormcutter) Picture-TBA~~

~~Sunblaze (Fireworm Queen) Pic-TBA~~

Iceclaw+Iceclaw+Iceblaze+Icebreeze (Groncicles) Pic-TBA

Ambersong (Death Song) Pic-TBA

Silverwing (Razorwhip) Pic-TBA

 
  

 

Credits
In order of signature layout

Pins made by Nessie, found here

Star Sky picture by me

Green dragon page breaker gif found on second post of this topic

All dragon pictures by me

Star and Sharpspine Racing Banner by Jennifer Fire

TDR blue swish GIF by Nessie

TDR HTTYD 2 movie banner by Nessie

TCC Family Banners by unknown

All flaming lines in signature by Nessie

If you made something on my signature and I haven't credited you yet or I credited the wrong person,

please feel free to PM me about it!

 *rages* When is my signature ever going to finish loading ._. 

 

Ridji
Offline
Jarl
Joined: 09/06/2014
Sure but...

You're right about that people should instead pm admin(s) when there's a problem, and that maybe we should stop complaining, but there are two problems : first of all I heard there were 5 admins, but I only see Brynjolf here, and never saw the other 4 (Brynjolf must be exetremely busy). Also if there's a bug section in a forum, most people will post their problems here. Also nothing is said about messaging admins, excepted when you make a post and someone tells you to do so. Second problem is people will still complain, for the simple reason that the bugs are making the game nearly impossible to play (can't farm, some can't fish, can't complete some quests, and other unexpected glitches...). Maybe it's a game that's "young", it's sure is a year old, maybe it's not the worst of all compared to some other games, but when there are still the same glitches remaining for months, this is a problem, especially when the said game is about a very good and popular franchise that made the best movies and serie. This game is awesome, it has great ideas, it is loveable, people love it, but those glitches even the smallest ones makes it frustrating, and even sometimes impossible to play. You want to play this game, because you like the concept, you like How to Train your Dragon, you can have an awesome time in this game, but sometimes you suddendly can't play.

Also I think that it's possible to fix all these bugs, and it should have been done months earlier. I've played some other games that back then were all new, and I can tell you they really can make a big change in a year. I think this game will get better if the fixes get implemented, and the sooner the better, as I think most people have big expectations for this game.

Then I don't know how the staff exactly works on this game, if they have the time to code and fix things, we don't really know what they are working on at the moment; are they fixing the glitches or will they again add things to the game ? We don't really know, we'll see on the next update I suppose.

So just wanted to share my thoughts on that, hope everyone have the nicest days.

alexpanciera87
Offline
Jarl
Joined: 09/08/2014
Oh, will wonders never cease...

Managed to survive long enough to be sent OUT of the School map and into the Wilderness zone, was pretty excited about that.  Surprisingly, the game managed to hold together pretty well for a while, until Mulch gave me cash and told me to buy a minnow.  Bought the minnow, and...  Nothing.  The flag did not trip.  Tried fishing with it of my own volition, achieved nothing.

 

Decided to try that whole 'restart the game' thing and see if that helped.  Initially, I thought it did, because it told me to return to the School zone for a quest.  That quest was the Rail Shooter game.  Which I had already done.  I gave it the benefit of the doubt and assumed that you were being sent back to try a higher difficulty, and when Snoutlout's speech got pre-empted and I found myself going through a different track than the last time I thought I was right and as soon as I got through it I'd be given something NEW to do.

 

Silly me for assuming this game was actually WORKING.

 

Finished the rail shooter, got told to go talk to Bucket.  Which I had already done.  Hoping that this was simply a case of them recycling the opening of a quest I went over to him...  And got the EXACT SAME QUEST I HAD ALREADY DONE FOR HIM.  My attempt to deal with Mulch's quest going kerplooie had trapped me in a Groundhog Day loop.

 

At that point I said "&@%$ it, it's after ten here, I'm going to bed."