4 active quests, 4 glitched quest. I can do nothing. HELP!!!!!

3 replies [Last post]
DragonWhisperer420
Offline
Jarl
Joined: 10/25/2016

Hi! I Hope this is the place for this. First off, let me just say how much I freaking LOVE this game!!! But that being said, it's getting to be a moot point. I have been trying to find a solution for my quest problems for over a week now. It took me that long to just get approved to post on the forums. While I was waiting, I did my own research, cleared all caches (unity included), re-installed, tried it on 2 other platforms, the works. Nothing changed. I even sent a support request in, but have heard absolutely nothing. Same with my request for help on the facebook page. I'm getting really really fed up. I became a paid member mainly for the added quests, and now I can't even play two of them! Ok, sorry, had to get that out first. Now on to the specifics. The first glitch I encountered by during the experiment portion of Grockle Iron. I could start the experiment just fine, but by the time it wanted me to cool the wood ashes after using the feather, the ice feature was gone. No other buttons would work, either. The only thing I could do was press the back arrow and exit/give up on the experiment. Which wasn't really a big deal at the time, because I had tons of other active quests, so I just went about my business, begrudgingly forgetting about Gronckle Iron. Fast forward a bit through quest (and after being a paid member for the next 3 months), I discovered that whenever I had a quest asking me to go to the lab, no matter what quest I had active at the time, the gronckle iron one would be the experiment to load, glitch included. Now I have three quests directing me to the lab (Gronckle Iron, The Almighty Thor, and, the one I'm most upset about, the Death Song story line) and I can't get any farther on any of them. So I keep going about my business, completing the quests that I can. Until, that is, I only have 4 left; the 3 at the lab and "In the Belly of the Beast," which brought me to my second glitch. I started playing ITBOTB with no problems. Until I got to "Tap on Harald and lead him through the tunnel." Problems being with that are 1.) The only place Harold is is Dragon's Edge, and while he does have a ? above his head, he doesn't respond to any interaction with him. Clicking does absolutely nothing. So I warp to Dragon Island, and try to just head into the tunnel, through either opening. And encounter problem 2.) Once I have entered the tunnel to go inside the volcano, the load screen comes up and never goes away. I have to force close game because I can literally do nothing else. So that is my dilemma. 4 active quests, 4 unfinishable quests. Please. PLEASE PLEASE PLEASE someone help. Or credit my membership money back. Because yeah, what's the point in being a paid member that can't play...  ::sob::

 

FYI:

User Id: Dragonwhisperer420

Viking Name: Thyra Odinsol

 

PS- I am also experiencing a glitch with one of my dragons not ever saving it's name/customization after signing out, but honestly, that is small potatoes in comparison to the quest problems. I'm rename/color my dragon every day if I can just play the darn game.

 

spfairy's picture
spfairy
Offline
Wilderness Explorer
Joined: 07/15/2016
Who needs a forum subject when you have dragons?

The same thing happened to me, I decided to make a new viking and just wait to do the Gronckle Iron as my last quest I have in the game to see if it is fixed. I hope it gets fixed soon.

__________________

Welcome to my signature!

In-game name: Sunwatcher

Number of dragons: 18 counting eggs that are hatching.

First ever dragon: A Flightmare dragon named Dark Secret.

                              MY DRAGONS:

DarSecret: Level 20 Flightmare

Electric Silver: Level 21 Skrill

Fog Shadow: Level 14 Smothering Smokebreath

Morning Song: Level 18 Death Song

GlorSound: Level 11 Changwing

Snow Fall: Level 19 Groncicle

Sharp Stone: Level 9 Razorwhip

Emerald: Level 11 Grapple Grounder

New Fire: Level 10 Singetail

Milkshake: Level 9 Mudraker
Frost: Level 5 Deadly Nadder

Winter: Level 3 Shivertooth (Used Skip to Broad Wing stage on him)

Storm: Level 4 Raincutter

Pyrite: Level 1 Gronckle

Aspem (My misspelling skills are bad...): Level 1 Scuttleclaw

Ossis: Level 1 Boneknapper

Ocean and Sea: Level 2 Hideous Zippleback

Seaweed: Level 1 Thunderdrum

 

DragonWhisperer420
Offline
Jarl
Joined: 10/25/2016
Bumping this back up to the

Bumping this back up to the top, because yeah, still nothing being done...

LucyintheGround
Offline
Jarl
Joined: 10/27/2016
Same Problem Here

I'm having the same problem with the eternal loading screen when trying to enter any of the tunnels in Dragon Island.  My membership just expired without me being able to complete the quest.  Now I can't access the island without renewing my membership.    

 

I have tried clearing all caches, uninstalling the game, restarting the computer, even creating a new viking.  The new viking has the exact same issue with Dragon Island and now the Dragon Hunters den won't load either for that viking.

 

User Name: LucyintheGround

Viking Name #1: LucyUnderGround

Viking Name #2: Sorkana

 

Please le me know when this gets fixed since I would love to renew my membership if it does!

 

Thank you.