Wide Game Resolution Issue

4 replies [Last post]
NobleStorm's picture
NobleStorm
Offline
Supreme Viking Champion
Joined: 07/27/2014

Restarting the game and my laptop (MacBook Pro) didn't help. I'm not sure if this was caused by my second display screen (a drawing tablet) which I have been using for awhile now and hadnt had this issue before.

My FPS also seem to have dropped a lot, not sure if the problem is related.

I also attempted to resize the game window which doesn't work.

 

__________________

"I'm sorry, the old noble can't come to the phone right now.

Why? 

Oh, cause she's dead."

Currently known as Azulean

Click the button to check out my DeviantArt :)

 

 

Varku's picture
Varku
Online
Supreme Viking Champion
Joined: 06/14/2015
~

It's not a dual-screen issue. Did you try to resize the window by alt-clicking the shortcut?

__________________

Small Signature Squad-- because we don't hate people and neither should you.

 

 

 
Neo // some artiste terrible
has no idea what's going on

 

more cool links:

 

Peepo the most Powerful: King of the Night Furies ©

NobleStorm's picture
NobleStorm
Offline
Supreme Viking Champion
Joined: 07/27/2014
.

Tried it out but it didnt work, thx for suggesting though. Reinstalling the game also does nothing

Varku's picture
Varku
Online
Supreme Viking Champion
Joined: 06/14/2015
~

Kind of seems like your GPU is handling those settings, then. You might have to look into your graphics settings and maybe reset them to the default settings if possible.

Strykana's picture
Strykana
Offline
Supreme Viking Champion
Joined: 04/25/2014
~

I also have a MacBook Pro and have dealt with this issue several times... the problem with SoD, is that it will remember your computer's last resolution settings only since the game's last update... and because you probably have dual graphics with Retina, the issue with these MacBooks is the weird way they share the dual GPUs in dual screen mode... 

 

Here's the quickest remedy that should work for you:

First, open  System Preferences -> Display

Make sure the option for "Default for Display" is selected. 

 

Open SoD and make sure it's in full screen mode.

 

Now, change the game's Quality Settings to a setting you

don't normally use or haven't used (Low, Medium or High).

Let the new files download. (This will refresh SoDs memory of your screen resolution)

 

Enter the game, then quit and close SoD.

 

Restart your Mac and Relaunch SoD.

---------------

If that doesn't work... there's another option (that I use for various reasons) that involves using the app "QuickRes", which allows you the ability to choose all the resolutions your MacBook supports. Using this app allows you to customize the size of SoD while it's in "windowed mode"

 

As long as you select a resolution with the same ratio as your native resolution, you can customize the size of SoD in its "windowed mode" without affecting how it looks in full screen.

 

Below is a screenshot of the size that I like for SoD in its "windowed mode"

(I chose 2880x1800), because it allows me to multitask on my desktop easier.

(I have a 15" MacBook Pro using the default resolution of 1440x900 Retina)

 

And this is how it looks in full screen mode.

 

__________________