unable to play?

1 reply [Last post]
Strawberryfiz
Offline
Drott
Joined: 06/17/2014

I recently wanted to come back to SoD after many years of not playing. I decided to open the game but, to my surprise, the game wouldn't load whatsoever. The window pops up as if I am to start playing, however, the screen remains black no matter how long I wait. My computer also sounds like it kicks into overdrive when this happens, though nothing ever loads.

I've tried deleting and redownloading the game, but the same problem persists. I've run multiple checks for system updates on my computer but nothing has solved the problem. My computer is Windows 10 and it should meet the other requirments that were listed in the tech support forum. 

I redownloaded the iOS game onto my iPad and it works just fine on there, so I don't believe it has anything to do with my account.

A little while ago, I tried to run the Shelter 2 game which runs through steam. The same problem appeared for that game as nothing but a black screen was loading. I fear this issue may have something to do with my computer, but I have no idea what I can do to fix it.

please advise!! I'm stumped and I don't know what to do to fix this!!

__________________

Tamra Diamond's picture
Tamra Diamond
Offline
Supreme Viking Champion
Joined: 05/20/2016
Natsu, are you all fired up?

It's been the same for me, everytime I install the game and try to open it, the sound starts to play but nothing than black screen happens. Oh well

__________________

 

Ciaossu! ^^

I started play SoD again a little bit, find me under name: UravityDiamond

I also play SoulWorker!

Add me as friend if you play Howrse: Tamra

Follow me on Pinterest: FireDiamond

Feel free to talk to me about anything and anytime! 

 

http://i63.tinypic.com/ao2t7d.jpg

(Made by Knight of Fury)

__________________________________________________________________________________

https://66.media.tumblr.com/4d4c096cf45bd07e1e683a9c7b812ef5/tumblr_nphqptDTXv1uu7byeo1_500.gif

http://66.media.tumblr.com/tumblr_m9uui6fflg1qlubn1o1_500.gif

http://25.media.tumblr.com/tumblr_m8wzn0wLnG1rziwwco1_400.gif

DRAGONS <3

http://peterorrestad.com/wp-content/uploads/2014/06/gif-review-2.gif