Stoick is gone, how do i finish my quest?

5 replies [Last post]
NinaByTheWay
Offline
Forager
Joined: 05/17/2016

So when i finally got enough gems to by icestorm island and finished almost all quests, the last one wants me to go to stoick, but he is no longer among the living, now what? Even the quest arrow doesn't know where to go

Varku's picture
Varku
Online
Supreme Viking Champion
Joined: 06/14/2015
~

Have you tried closing the game, clearing your Unity cache and restarting?

__________________

Small Signature Squad-- because we don't hate people and neither should you.

 
Neo // poopoo drawer
 

more cool links:

 

 

Peepo the most Powerful: King of the Night Furies ©

Madness's picture
Madness
Offline
Berk's Power Player
Joined: 01/08/2015
It should tell you to go to

It should tell you to go to Valka, but if your game isn't updated it will glitch and the quest arrow will go wonky. Try going to berk and talking to Valka, or Stoick. My game wasn't updated and it told me to go to Valka, but Stoick was still there. I hope this helps. :)

 

It probably doesn't but I wanted to try. :)

__________________

My Signature:

 

My Oc's

 

Spiral

(Art done by catiedragons!)

 

Spiral is a rather hyper whispering death, coming up to the surface more than often to scare my chicken. He is still young, just big enough to ride on which may explain most of the hyperactiveness. Like most young whispering deaths, his teeth are hard to control, sometimes sending him haywire when he is underground, but for the most part he can control it. These two features make him an amazing racer. Due to his his hyperactiveness he can go faster than most dragons, still struggling though to always stay in control. This is something we are working on, but it's diffucult with a whispering death. (Don't judge me) If you notice, he has a scar in the corner of his tail. This is because of a large rock falling onto him when he was younger. The only way he could get out was by burying under it, but he ended up cutting his tail with a sharp edge of the rock. He still avoids larger rocks, being agressive to them, even though it doesn't scre them away.  I still hope that he can eventually become in more control of himself, but I don't mind it much right now. I can't say the same for my neighbors....

 

Chicken

(Art done by nightfuryatom4!)

Chicken. He is my chicken. Whenever someone sees the chicken they ask, "Will you eat him?" The answer is no. So never ask that question. You'll seem stu.pid. He can often be found waddling behind me in my posts, but he mostly lives in my subject, no matter how many times I tell him to leave. 

 

ADOPTABLES!!!!!

 

Aquaborealis: (By Spy and Kcrockett)

 

 

 

Darwin my Aquaborealis!

 

 

Riptide my Aquaborealis!

 

 

 

 

 

Riptide in a chibi base! 

 

 

(I have removed Midnight as Riptides mate and my signature out of respect for her owner)

Moonstone! Daughter of Midnight and Riptide!

 

 

Ashur! Son of Riptide and Crescent!

 

 

Lilie! Daughter of Riptide and Mossy Vapor!

 

 

 

Rivercloud!

 

 

 

Cirrus! Son of Rivercloud and Fleur!

 

Ventus!

 

Saffron!

 

Tirian! My Albino!

 

 

Twinmint!

 

Brakebone: (By Sky and Ocean)

 

 

 

 

Havok!

 

 

 

Pan Puffle: (By Sky and Ocean)

 

 

Squishy!

 

 

 

Spike Rollers: (blackpanther for idea/Nightmarerebuff for lineart)

 

 

Spikeclaw!

 

The Thunderthief (Wutend Bonfire)

 

Thunderspine!

 

The Chiropan: (Nightmare Rebuff)

 

This Chiropan is based off a....Tiki!

Dale my Mountain Jackoat by ScarfyWings!

 

 

NinaByTheWay
Offline
Forager
Joined: 05/17/2016
Well.....

Didn't work, thanks for the help but it's still the same and to top it off, now the death song dissapeared, just when was supposed to get it off the hauses in berk

Saltemoon
Offline
Jarl
Joined: 05/30/2016
Same

The same thing is going on for me.. Cant he just appear for this quest? This quest will just rot in my journal until stoick magically comes back or somehow I can reach contact with him. Not everyone finished Icestorm island SOD....

Shockfrost's picture
Shockfrost
Offline
Berk's Power Player
Joined: 09/06/2015
-sigh-

I get the feeling you're supposed to talk to Valka instead of Stoik.  However, since that doesn't work, we've got to wait until someone realizes that they borked old quests with the new expansion (a shocking twist, I know.  I'll let you recover from that) and fixes it.  I got stuck here and on the Call of the Death Song because the map doesn't load the amber surrounding Berk's houses, I presume due to the Berk map being set in a different state by the 2.0 update.