So, Um, No Daily Reward...

3 replies [Last post]
DragonTrainerV's picture
DragonTrainerV
Offline
Chief
Joined: 01/07/2015

So, as the title says, I got no reward, today for one of my vikings -- I logged into an old account a while ago to see how old my first dragon was, realized it had a lot of stables and potential, and have started playing on that account, again.  I was on the last day of rewards, and started up the game to get my 30 gems.  As I always do, I went to the stables first, checked the dragon quests, and headed outside to the school where I usually get the reward.  However, when it started loading... it never stopped.  I waited for a solid 5 minutes for the daily rewards to come up (and couldn't do anything while it was loading), but nothing happened.  I decided to close and reopen the game because that's just all I can do when I get a loading glitch (which happens very often).  When I came back in, no reward or a mention of it.  So can I expect to get this tomorrow, or will it just shoot me back to the first day?  I'm willing to bet the first day knowing them, but I'm just hoping to get a little help.  Thanks.

__________________

 I will be updating my Signature soon. I am just lazy.

Friend Code: NON30fy0ur8u51n355

I am a lazy potato. You're all welcome.

 

 

Jrla
Offline
Jarl
Joined: 06/12/2018
Spidey ripped my subject *sighs*

Just keep on playing! This happens to me all the time. The daily rewards won’t pop up.... but then, I just continue playing. I exit and open my SoD again and again, then after some time, the daily reward will come! :D

 

it may be because you first logged at (for example) 12:00, you’ll get your reward at 12:00.... you can’t get it at 11:00 or 10:00 or so on.... only at 12:00 onwards.

DragonTrainerV's picture
DragonTrainerV
Offline
Chief
Joined: 01/07/2015
OwO

Unfortunately, this is not the case.  I logged in this morning, and I've been trying all day.  It's now almost 12 hours, and still no reward.

Jrla
Offline
Jarl
Joined: 06/12/2018
Spidey ripped my subject *sighs*

Oh. Then if that’s the case... I think you should contact the admins. That’s all I could advise you to do... Sorry!