Is it just me or...?

1 reply [Last post]
Redifiron's picture
Redifiron
Offline
Jarl
Joined: 06/13/2019

For the past 2 days, the game has been nearly unplayable for me. I keep getting the never ending loading screens and I actually have to enter the game by using the stable button on the character select screen to get it to have any chance of loading at all. When I actually manage to get into the game some quest text won't load and I can't perform some actions (like chopping trees in the wilderness). I've restarted and even redownloaded the game multiple times but nothing has changed. I actually can't access my main viking at all because if I select her from the character screen, it'll load in my dragon but my viking won't load and I get the infinite turning gears of death. Am I the only one having problems? I'm playing on the download version for PC, and I've tried both it and the steam version on different computers with no improvement whatsoever.

__________________

(Signature under construction)

 

Viking Name: Eiradene

Viking Age: 20

Real Age: 17 (A little old to be on this game. I know.)

Friend Code: GDYJKG

Dragon Count: 22 (Not including unhatched)

Adventurer Level: 50

Clan: Dramillion Warriors

 

About Me:

I started playing SoD the first year it was released. I played for 2 or 3 years before I took a really long break and just recently decided to give the game another go, considering I'd always loved it before. Unfortunately, I lost access to my old account because I no longer have access to the email I signed up with. So, I had to start from scratch! I think I'm doing pretty good for myself considering I'd only been playing for a couple of weeks at the time I joined the forums. You can get a lot done if you play for hours every day like I have.

 

Dragon List

 

Key: Hatching/Unhatched Eggs/Baby Dragons/Teen Dragons/Adult Dragons/Titan Wings

 

Male Rumblehorn (Level 12)

Male Monstrous Nightmare (Level 29)

Toothless - Male Night Fury (Level 8)

Female Light Fury (Level 19) (I call her Echo)

Male Groncicle (Level 10)

Male Razorwhip (Level 21)

Female Death Song (Level 25)

Male Armorwing (Level 2)

Male Singetail (Level 6)

Male Eruptodon (Level 3)

Female Flame Whipper (Level 6)

Female Whispering Death (Level 10)

Female Gronckle (Level 3)

Unnamed Unhatched Female Triple Stryke

Male Elder Sentinel (Level 3)

Male Deathgripper (Level 5)

Male Dramillion (Level 10)

Male Silver Phantom (Level 10)

Male Stormcutter (Level 4)

Male Scuttleclaw (Level 9)

Male Sand Wraith (Level 4)

Male Wooly Howl (Level 4)

Male Crimson Goregutter (Level 4)

Female Skrill (Level 1)

Unnamed Unhatched Female Stormcutter

 

Avengers Themed Dragons!

(Because I'm a neerd)

(Section under construction. I have to finish obtaining these dragons and I also plan to add pictures! I picked 9 characters from the MCU and decided to design and name dragons after them. It's probably obvious from the dragon list which ones are themed but I figured I might as well categorize them here too.)

CoalBright
Offline
Chief
Joined: 06/27/2016
I've beem experiencing this

I've beem experiencing this problem all day long; game has been totally unplayable, today.

 

My problems started and continues everytime I go to my farm, touch the job board or touch the store button. And then I have more trouble, when I try to return to the stables. I can't even get another dragon to play with . . . 

 

I've done multiple uninstalls of the game, computer restarts, and then multiple downloads and installs of the game with latest updates. Nothing worked right, but I kept trying. Did the proceeding 8-10 time, finally it installed correctly and I was in for a few minutes, but then I try to get back to the stables. Bad mistake. . . spinning wheels, etc. etc. These Problem continue. . . .

 

Computer: Desktop PC

OS: Windows 10

Web Browser: Chrome

What were you doing when the bug occurred?: At my Farm or attempted to use Lookout/New Berk Job Board or tried to buy crops/animal feed at the Store. Attempted to change my dragon or return to stable. Any and all of these and I get stuck with Spinning Wheels or continuous loading screens that never end. 

When did the error occur: With the first login I made this morning and during repeated attempts to login and play. Problem occurs everytime I touched one of the option buttons related to: Farm, Job Board, The Store, and Stables. Also occurs when I attempted to move to or from Farm/jobBoard at Lookout or NewBerK/Stables. 

Screenshots: NOPE

 

UPDATE: Late in evening I logged back into game; no spinning wheels or loading screens problems. And no reactions with farm, job board, the store, etc. Everything was working fine and able to play.  chopin2014, I hope your login problems have cleared up, as well. 

 

CB