invisible Stormheart ship: won't let me continue the quest

No replies
echalkley
Offline
Jarl
Joined: 07/05/2017

I'm currently trying to complete the Wrath of Stormheart. I was able to get Fishlegs out of his cage and exited the game. The next time I logged in, it told me to do the whole "click on the cage" to let Skulder out routine again. So I figured that I might as well try it again, but something went wrong and I exited the game to see if it would reset somehow. It didn't. Now when I go the the Dangerous Waters where Stormheart's battleship is supposed to be, all I can see are all the people walking around ON AN INVISIBLE SHIP! Skulder is still just standing mid-air in that storage room (everthing invisible --he's just hovering over water), Fishlegs is in the cage again over the water, and Hookfang and Snotlout are hanging out on the invisble lower deck. The guards are walking around above on the invisible upper deck. There's nothing for me to click on. I tried waiting to see if the problem would fix itself but it's been over a week. I had hoped this big 05/30 update would fix the problem but it's still the same.