Can't Play SoD, Getting Really Frustrated...

5 replies [Last post]
Alphie's picture
Alphie
Offline
Viking Warrior
Joined: 07/22/2015

Okay this is ridiculous. None of the ways I can get into the game are working. I have tried doing all the fixes I know of, (clearing caches, uninstalling/reinstalling, using different a browser/versions of the game) and none of it works.

Chrome gives me this message: 

Please follow these steps to play it on Chrome:

a. In chrome url bar type: chrome://flags/
b. Go down to Enable NPAPI Mac, Windows and select Enable
c. Scroll down to Restart Chrome
d. Come back to game and play

But when I follow the steps it gives me to a tee it says the exact same thing.

 

 

 

Internet explorer is only giving me the option to install Unity but when I try to it gives me this:

 

Forbidden

You don't have permission to access /download_webplayer-3.x/3.0/co/UnityWebPlayer.application on this server.

Apache/2 Server at cdn2.unity3d.com Port 80

The Desktop version of the game crashes after I have signed in and try to access my character. It then gives me this message (There in no file I could find by that name.):
And a different message as well after I uninstalled it and reinstalled it:
This started 3 days ago. At first The game would just crash whenever I tried to go to The Lookout. Now I can't play my game at all. I have paid to play this game and I can't. I love the game itself but if this keeps on happening I'm going to stop playing. Help me. Please.

__________________

Drawing dragons...

 

Lapis_Lupus's picture
Lapis_Lupus
Offline
Dragon Master
Joined: 06/12/2015
Don't get your undies in a bunch

Have you tried it in Firefox? Or the Windows App, if you run DOS?

 

I have no why this would have taken until three days ago to kick in for you, but for a while now Chrome has completely dropped support for Unity WebPlayer. And by a while, I mean a few months ago. So it makes perfect sense that you would not be able to play S.O.D. at all in that browser. Unless...could you have received an update for Chrome three days ago that made the new protocol finally kick in?

 

I haven 't the foggiest how or why IE won't work for it. That stuff is crap, haven't used it in what feels like years. I deleted it off my Windows 7 laptop and stick to Chrome/Firefox, and my Windows 10 laptop is blessedly free of it. Personally, it's too dangerous and exploit-ridden to be good for anything these days in my opinion.

 

The desktop version does not ever work for me either. More than a few people seem to have been encountering that, or noticing that the game in fact runs better for them in a browser (despite the game itself's claims to the contrary). I try to log in and the game does not load after the username/password are entered.

 

Well then if you haven't done so, I recommend using Chrome (or IE, if you must) to download Firefox and run it in that browser to see if it's any better. And like I said, if you have a Windows system 8 or better, try the app version of the game; this might not though, for whenever I try that app it will not accept my username/password no matter how many times I try, saying they do not match.

__________________

Gif made and originally posted by: stworzydlak

Banner made and originally posted by: Aurora the Swift

Alphie's picture
Alphie
Offline
Viking Warrior
Joined: 07/22/2015
Okay, so the good news is

Okay, so the good news is that Im at least able to get into my game with Firefox, yay! The bad news is that the game still freezes as soon as I try to go to The Lookout.. any ideas on what can be done?

dragonrider1a's picture
dragonrider1a
Offline
Supreme Viking Champion
Joined: 01/17/2015
Your not the only one

I constantly have the "Oops! Game crashed" message. And although the crash messages are common for me, it is worse when I'm in the Lookout. I haven't tried to reinstall it for fear of that same Error message you experienced happening to me, and I thought I did everything possible to try and fix it XD

 

Edit: It's gotten to the point where I can only be in the Lookout for a couple of seconds. I've started to avoid it as much as possible. The only hope I can see for you're Lookout issue is to contact an Admin.

__________________

    Signature Under Construction due to photos not appearing!

 

I'm in Star Stable!

More info at the end of my signature!

 

 Viking Name: DragonQueenofBerk

Level: 35

Main Dragons: Zinc, Scorpion, Apollo

Species: Male Titan Razorwhip, Male Triple Stryke, and Male Seashocker

Clan: The Dragon Guard

Position: Leader

 

*Expansion Packs Completed:

Icestorm questDeathsong questBattle questRtdi iconTsol icon 2

 

 

Dragons from the Expansion

Here are pictures of the dragons I recived from the expansions:

 

UNDER CONSTRUCTION!

 

 

 

 

Credits:

Clan Banner from: http://www4.flamingtext.com/

*Expansion symbols not mine, found on google*

 

You can also find me in Starstable!

 

To view my Starstable info, click the link below:

https://docs.google.com/document/d/1Y6rn_3ptq6DzE_PdS1iDSGK3ZeJrSHBaOSulOawxUh8/edit?usp=sharing

(let me know if it doesn't work!)

 

Alphie's picture
Alphie
Offline
Viking Warrior
Joined: 07/22/2015
I talked to Siren about it,

I talked to Siren about it, she said she is going to try and fix it. Hopfully it will be fixed soon, I used my farm alot. :( For me the game just up and freezes on the loading screen. I wonder what is so weird about The Lookout that makes it so finicky...

JasonSenan's picture
JasonSenan
Offline
Jarl
Joined: 05/02/2018
It's still happening did

It's still happening did your's get fixed?