Anyone else having this problem?

2 replies [Last post]
DragonMaster9242's picture
DragonMaster9242
Offline
Supreme Viking Champion
Joined: 03/30/2014

I'm trying to buy a boulder stable with coins and it ain't working. I get an error "Purchase failed." This happened to me once before and it was because the game showed my coin count as more than it actually was, and restarting fixed it. I've restarted 4-5 times now and still the same results. I have trial membership rn and 2808 coins. 8 coins more than I need to buy the stable.

 

On that same not, I can't buy 400 coins for 48 gems. I have 51 gems.

 

I'm thinking maybe it's not registering taht I have an active membership and is charging me the non-member price? I really need thsi stable to hatch my Grapple Grounder and make the most of Toothless.

__________________

 

Signature Under Construction!<3

 

 

 

 

 

 

Hello friends and welcome to my signature <3

I have loved the HTTYD series ever since its release in 2010 (I was only 6 at the time). 

 

 

 

 

 

Warning: This user has a strange obsession with multiple fictional characters. Please frown upon her so she feels bad about it.

 

 

 

 

My Dragons:

 

Electrifying - Skrill

 

Poison - Deadly Nadder

 

Moonglow - Flightmare

 

Earthripper - Whispering Death

 

Kamatay - Triple Stryke

 

Blue Spark Lizard - Singetail

 

Allegro - Slithersong

 

Viggo - Grapple Grounder 

 

Toothless - Night Fury

 

Mercy - Stormcutter

 

Storm - Raincutter

Valor - Woolly Howl
 

 

 

Dragons I Want

 

Smothering Smokebreath

Speed Stinger

Night Terror

Death Song & Razorwhip (My expansion pack bugged out so I can't get them.  Since said bug has been happening for months I don't think it'll be fixed any time soon. :c)

Snow Wraith (I'll have every Strike Class dragon >:)

Changewing

 

DragonMaster9242's picture
DragonMaster9242
Offline
Supreme Viking Champion
Joined: 03/30/2014
Just realized - I'm being

Just realized - I'm being charged the non-member price for items even though I'm a member, which was indeed the issue, despite the fact that the price displayed in the store is the member sale price. Whats up with that?

Concept01kay's picture
Concept01kay
Offline
Jarl
Joined: 02/03/2018
Werid

I have had this problem more then once but i either #1 re-install SoD or #2 X out the game and re-log back in. But its my tips i hope it helped! if it didnt i hope admins will help you with the situation! Take Care! & Goodluck! ^^

__________________

                                              DeloraFierySapernt

 

 

 

Image result for BewilderBeast